The RAPi Project Update

With every few steps forward on this project, I inevitably take a step back. On Friday night I successfully created a 2 node Pi computer. I tested it with the MPICH2 script and it indicated that both nodes, RApi0 and RApi1, were talking to each other. This was a HUGE accomplishment for me.  Just to get this point was a pain in the butt because of SD card corruptions and faulty image writing, but the time was well spent.

Saturday evening I then started the process of installing Apache, PHPmyAdmin, and MySQL, as the backbone for getting Rapid Analytics 1.3 to work. Everything installed well and then I downloaded and installed Rapid Analytics.  I went through the configuration quickly and set the hostname to RApi0. Then I set my parameters to load Java and run the Rapid Analytics JAR file. The server started within 6 minutes! WOW! Awesome! But then I couldn’t get to view the configuration screen in the browser. I was pointing the URL to http://localhost:8080.  At this point it was 1AM and I was tired, I decided to power down and restart tomorrow with a fresh mind.

Sunday morning I restarted both RApi0 and RApi1 and fired up JAR file again. This time, it churned and finally crashed out. Out of Memory Exception. Damn! What went wrong?

My initial thoughts on what went wrong was this, and I welcome any of my readers to chime in with suggestions (please!):

  1. I installed MySql, Apache, PHPmyAdmin, and Rapid Analytics on my head node, RApi0, and when I powered up on Sunday morning, MySQL and Apache started on RApi0. I believe that this could be an issue because it didn’t load into the shared resources of RApi0 and RApi1. I welcome your thoughts!
  2. Setting the hostname in the RapidAnalytics 1.3 to RApi0 meant that I should’ve pointed my browser to http://RApi0:8080. Ugh.

My next steps is to power up the 2 node Pi and manually start up Apache and MySQL once both Pi talk to each other, then start the JAR.

]]>